Back to overview
Maintenance

Feedback Portal Maintenance

Apr 18 at 11:00am CDT  –  Apr 20 at 11:30am CDT
Affected services
nodecraft.com
Nodepanel 2 API

Resolved
Feb 01 at 10:31am CST

Maintenance is now complete. All systems have been restored. No game servers were affected by this maintenance window.

Created
Apr 18 at 11:00am CDT

We love getting user feedback on your favorite platform to launch Game Servers. The Nodecraft team is launching an entirely new experience for providing feedback on 4/20/2022.