Back to overview
Degraded

Upstream Global Outage

Nov 18, 2025 at 12:05pm UTC
Affected services
nodecraft.com
Nodecraft Pro API
Nodepanel Billing
Billing Portal
Nodecraft Studio API
NodeCDN API
Player DB
MC Versions
MC UUID
Steam ID

Resolved
Nov 18, 2025 at 02:54pm UTC

The upstream provider has officially marked this incident as fully resolved and all services are fully operational.

Updated
Nov 18, 2025 at 12:17pm UTC

Many services have returned with at least a partial resolution. We are continuing to monitor this incident with our vendor.

Your game servers remain unaffected.

Created
Nov 18, 2025 at 12:05pm UTC

An upstream provider is currently experiencing a global outage. This affects many of Nodecraft's core web and API services. You will not be able to manage or purchase new game servers; however, your game servers should be unaffected during this outage.