Back to overview
Degraded

Dashboard Unavailable

May 11, 2026 at 11:20pm UTC
Affected services
nodecraft.com
Nodecraft Pro API

Resolved
May 12, 2026 at 2:14am UTC

This issue has now been resolved.

Updated
May 12, 2026 at 12:34am UTC

We have implemented a fix and are monitoring the results.

Updated
May 12, 2026 at 12:15am UTC

We are continuing to investigate this issue.

Updated
May 11, 2026 at 11:51pm UTC

Our team have rolled out a fix for this issue and are monitoring the results.

Created
May 11, 2026 at 11:20pm UTC

Some customers may be unable to access parts of the Nodecraft dashboard and control panel. Game servers are unaffected.

Our team is investigating this issue.